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Warning!
Before commencing the installation

Disconnect the power supply of the device.

Ensure that devices cannot be accidentally restarted.

Verify isolation from the supply.

Earth and short circuit.

Cover or enclose neighboring units that are live.

Follow the engineering instructions of the device concerned.

Only suitably qualified personnel in accordance with EN 50 110-1/-2 (VDE 0 105 Part 100) 
may work on this device/system.

Before installation and before touching the device ensure that you are free of electrostatic 
charge.

The functional earth (FE) must be connected to the protective earth (PE) or to the potential 
equalization. The system installer is responsible for implementing this connection.

Connecting cables and signal lines should be installed so that inductive or capacitive inter-
ference do not impair the automation functions.

Install automation devices and related operating elements in such a way that they are well 
protected against unintentional operation.

Suitable safety hardware and software measures should be implemented for the I/O inter-
face so that a line or wire breakage on the signal side does not result in undefined states 
in the automation devices.

Ensure a reliable electrical isolation of the low voltage for the 24 volt supply. Only use 
power supply units complying with IEC 60 364-4-41 (VDE 0 100 Part 410) or HD 384.4.41 
S2.

Deviations of the mains voltage from the rated value must not exceed the tolerance limits 
given in the specifications, otherwise this may cause malfunction and dangerous opera-
tion.

Emergency stop devices complying with IEC/EN 60 204-1 must be effective in all oper-
ating modes of the automation devices. Unlatching the emergency-stop devices must not 
cause restart.

Devices that are designed for mounting in housings or control cabinets must only be oper-
ated and controlled after they have been installed with the housing closed. Desktop or 
portable units must only be operated and controlled in enclosed housings.

Measures should be taken to ensure the proper restart of programs interrupted after a 
voltage dip or failure. This should not cause dangerous operating states even for a short 
time. If necessary, emergency-stop devices should be implemented.

Wherever faults in the automation system may cause damage to persons or property, 
external measures must be implemented to ensure a safe operating state in the event of a 
fault or malfunction (for example, by means of separate limit switches, mechanical inter-
locks etc.).

The electrical installation must be carried out in accordance with the relevant regulations 
(e. g. with regard to cable cross sections, fuses, PE).

All work relating to transport, installation, commissioning and maintenance must only be 
carried out by qualified personnel. (IEC 60 364 and HD 384 and national work safety regu-
lations).

All shrouds and doors must be kept closed during operation.
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About this Manual
Documentation Concept 

This manual contains all information about the TURCK FXEN product series for PROFINET in 
IP67. 

The following chapters contain a short FXEN system description, a description of the fieldbus 
system PROFINET, exact information about function and structure of the FXEN modules as 
well as all bus specific information concerning the connection to automation devices, diag-
nostics and data mapping. 
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Description of Symbols Used
Description of Symbols Used

Warning

This sign can be found next to all notes that indicate a source of hazards. This can 
refer to danger to personnel or damage to the system (hardware and software) and 
to the facility.

This sign means for the operator: work with extreme caution.

Attention

This sign can be found next to all notes that indicate a potential hazard.

This can refer to possible danger to personnel and damages to the system (hard-
ware and software) and to the facility.

Note

This sign can be found next to all general notes that supply important information 
about one or more operating steps.
These specific notes are intended to make operation easier and avoid unnecessary 
work due to incorrect operation.
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About this Manual
Overview

This manual includes all information necessary for the prescribed use of FXEN-modules for 
PROFINET. It has been specially conceived for personnel with the necessary qualifications.

Prescribed Use

Appropriate transport, storage, deployment and mounting as well as careful operating and 
thorough maintenance guarantee the trouble-free and safe operation of these devices.

Notes Concerning Planning /Installation of this Product

Attention

Please read this section carefully. Safety aspects cannot be left to chance when 
dealing with electrical equipment.

Warning

The devices described in this manual must be used only in applications prescribed 
in this manual or in the respective technical descriptions, and only with certified 
components and devices from third party manufacturers.

Warning

All respective safety measures and accident protection guidelines must be consid-
ered carefully and without exception.
D301136 0508 -  FXEN for PROFINET0-4
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PROFINET IO
PROFINET

PROFINET is the innovative open standard for the implementation of end-to-end integrated 
automation solutions based on Industrial Ethernet. With PROFINET, simple distributed I/O 
and time-critical applications can be integrated into Ethernet communication just as well as 
distributed automation system on an automation component basis. 

Distributed I/O with PROFINET IO

Distributed I/O is connected into communication through PROFINET IO. Here, the familiar 
I/O view of PROFIBUS is retained, in which the peripheral data from the field devices are peri-
odically transmitted into the process model of the control system.

Device Model

PROFINET IO describes a device model oriented to the PROFIBUS framework, consisting of 
places of insertion (slots) and groups of 
I/O channels (subslots). The technical characteristics of the field devices are described by the 
so-called GSD (General Station Description) on an XML basis.

Field Bus Integration

PROFINET offers a model for integration of existing field buses like PROFIBUS, AS-Interface, 
and INTERBUS. 

This allows the construction of arbitrarily mixed systems consisting of fieldbus- and Ethernet-
based segments. Thus a smooth technology transition is possible from fieldbus-based 
systems to PROFINET. The large number of existing fieldbus systems makes it necessary to 
support their simple integration into PROFINET for reasons of investment protection.

The integration is done with so-called "proxies". A proxy is a device which connects an under-
lying fieldbus with PROFINET. The proxy concept allows the device manufacturer, the plant 
and machine builder as well as the end user a high degree of investment protection.

Communications in PROFINET contain different levels of performance:

The non-time-critical transmission of parameters, configuration data, and switching infor-
mation occurs in PROFINET in the standard channel based on UDP and IP. This estab-
lishes the basis for the connection of the automation level with other networks (MES, ERP). 

For the transmission of time critical process data within the production facility, there is a 
real-time channel (RT) available. For particularly challenging tasks, the hardware based 
communication channel Isochronous real-time (IRT) can be used for example in case of 
Motion Control Applications and high performance applications in factory automation.

UDP/IP Communication 

For non-time-critical processes, PROFINET uses communications with the standard Ethernet 
mechanisms over UDP/IP which follow the international standard IEEE 802.3. 

Similar to standard Ethernet, PROFINET field devices are addressed using a MAC and an IP 
address. In UDP/IP communications, different networks are recognized based on the IP 
address. Within a network, the MAC address is a unique criterion for the addressing of the 
target device. PROFINET field devices can be connected to the IT world without limitations. 
A prerequisite for this is that the corresponding services, for instance file transfer, must be 
implemented in the field device involved. This can differ from manufacturer to manufacturer. 
D301136 0508 -  FXEN for PROFINET1-2



PROFINET

1
Real-Time Communication (RT)

A data communication over the UDP/IP channel is provided with a certain amount of admin-
istrative and control information for addressing and flow control, all of which slows data 
traffic. 

To enable real-time capability for cyclical data exchange, PROFINET abandons partially IP 
addressing and flow control over UDP for RT communications. The communication mecha-
nisms of the Ethernet (Layer 2 of the ISO/OSI model) are very suitable for this. RT communi-
cations can always run in parallel with NRT communications.

The Services of PROFINET IO

Cyclic data exchange
For the cyclic exchange of process signals and high-priority alarms, PROFINET IO uses 
the RT channel.

Acyclic data exchange (record data)
The reading and writing of information (read/write services) can be performed acyclically 
by the user. The following services run acyclically in PROFINET IO:
- parameterization of individual submodules during system boot 
- reading of diagnostic information 
- reading of identification information according to the "Identification and Maintenance 

(I&M) functions" 
- reading of I/O data

Address Assignment

In IP-based communications, all field devices are addressed by an IP address.

PROFINET uses the Discovery and Configuration Protocol (DCP) for IP assignment. 

In the factory configuration, each field device has, among other things, a MAC address and a 
symbolic name stored. These information are enough to assign each field device a unique 
name (appropriate to the installation).

Address assignment is performed in two steps: 

1 Assignment of a unique plant specific name to the field device. 

2 Assignment of the IP address by the IO-Controller before system boot based on the plant 
specific (unique) name. 

Both steps occur through the integrated standard DCP protocol.
D301136 0508 -  FXEN for PROFINET 1-3



PROFINET IO
Ethernet MAC Address 

The Ethernet MAC address is a 6-byte-value which serves to definitely identify an Ethernet 
device. The MAC address is determined for each device by the IEEE (Institute of Electrical and 
Electronics Engineers, New York).

The first 3 bytes of the MAC address contain a manufacturer identifier (Turck: 
00:07:46:xx:xx:xx). The last 3 bytes can be chosen freely by the manufacturer for each device 
and contain a definite serial number.

The MAC address can be read out using the software tool I/O-ASSISTANT. 

Note

The antecedent description contains a short overview about the properties and the 
functions of the PROFINET field bus system.
It has been taken from the brochure of the PROFIBUS user organization e.V. (ver-
sion 2006).
A detailed system description can be found in the standards IEC 61158 and 
IEC 61784 and in the PROFIBUS-guidelines and -profiles (www.profibus.com). 
D301136 0508 -  FXEN for PROFINET1-4



2 FXEN - General Technical Features

General Information .............................................................................................................2

General Information on FXEN...............................................................................................3

Address setting ...................................................................................................................4

PROFINET-Operation Mode.............................................................................................................. 4
Rotary coding switch setting "000" ................................................................................................... 4

GSD-Files .............................................................................................................................5

Connection Possibilities.......................................................................................................6

PROFINET.......................................................................................................................................... 6
Operation Voltage/ Load Voltage ...................................................................................................... 6
– Power supply via 7/8’’ (FXEN-XSG16-0001-PN) ........................................................................... 7
– Power supply via M23×1 (FXEN-XSG16-0005-PN) ....................................................................... 7
In-/ and Outputs ................................................................................................................................ 7

SET-Button...........................................................................................................................8

General Technical Data........................................................................................................9

Technical Data ................................................................................................................................... 9
Dimension drawings ........................................................................................................................ 10
LED-Displays ................................................................................................................................... 11
Diagnostic Messages via Software.................................................................................................. 12
– Diagnostic Messages (Slot 0 - "PROFINET-Communication") .................................................... 12
– Channel Specific Diagnostic Messages for the I/O-Channels (Slot 1) ......................................... 12

General Parameters ...........................................................................................................13

Description of User Data for Acyclic Services ..................................................................14

Description of the Acyclic Gateway User Data................................................................................ 15
Description of the Acyclic Module User Data.................................................................................. 16
D301136 0508 -  FXEN for PROFINET 2-1



FXEN - General Technical Features
General Information 

This chapter contains all information concerning the hardware of the FXEN modules, the 
general technical data as well as the connection possibilities, the addressing, the diagnostics 
and concerning the general PROFINET parameters.

Note

All module-specific information can be found within the module descriptions in the 
respective module-chapters of this manual.
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General Information on FXEN

2

General Information on FXEN

The FXEN-product family offers the following approved features: 

Suitable for PROFINET applications

Integrated auto-crossing Ethernet switch (line topology) 

Supported via FDT/DTM

Power supply via 7/8’’ or M23 x 1

Fibre-glass reinforced PA6 housing

Vibration and shock resistant

Encapsulated module electronics

Metal connector

Degree of protection IP67

Figure 1:
FXEN module

FXEN-module with 7/8’’ power supply:

FXEN-module with M23 x 1 power supply:
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FXEN - General Technical Features
Address setting 

PROFINET-Operation Mode

The modules FXEN for PROFINET are set to the PROFINET-operation mode (switch position 
"700") when delivered.

This mode assures a PROFINET-compliant operation of the modules.  

Rotary coding switch setting "000"

With the setting "000" of the rotary coding switches, the gateway is set to address 
192.168.1.254 for IP-based services. In this mode, for example the I/O-ASSISTANT can 
communicate with the gateway. A PROFINET-communication is not possible in this mode. 

Note

In PROFINET IO, the connected device is not identified by it’s IP address, but rec-
ognized and addressed by it’s device name.

The selection of a device name for a special IO device can thus be compared to the 
setting of the PROFIBUS address for a DP slave.

The device name can be freely chosen.

Figure 2:
Switches for ad-
dress setting 
with switch 
position "700"

Attention

The cover of the rotary coding-switches must be closed by tightening the screw af-
ter use.

The seal in the cover must not be damaged or slipped.

The protection class IP67 can only be guaranteed when the cover is closed 
correctly. 

Note

In order to be able to communicate with a gateway in PROFINET-mode - the rotary 
coding switches are set to "700" - using the software I/O-ASSISANT, it is first of all 
necessary to assign a valid IP address to the gateway. This can be done for example 
by using the HW-Config or the Primary Setup Tool from Siemens).

x 10 x 1

1
2

3
456

7

8
9 0 1

2

3
456

7

8
9 01

2

3
456

7

8
9 0

000: 192.168.1.254
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700: PROFINETx 100
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GSD-Files

2

GSD-Files

The modules’ actual GSD-files can be downloaded from the TURCK-homepage 
www.turck.com.

Table 1:
Name of the 
GSD-files

Module GSD-file

FXEN-XSG16-0001-PN GSDML-V2.0-Turck-FXEN16-JJJJMMTT.xml

FXEN-XSG16-0005-PN GSDML-V2.0-Turck-FXEN16-JJJJMMTT.xml
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FXEN - General Technical Features
Connection Possibilities

PROFINET

The connection to PROFINET via the integrated auto-crossing switch is done using 2 
M12 x 1-Ethernet-female connectors.

Operation Voltage/ Load Voltage

The power supply is realized either via a 7/8" or via a M23 x 1 male connector on the module.

Figure 3:
Pin assignment 
of the M12 x 1-
female 
connectors

Female connector M12 x 1

Note

The operation voltage (UB) and the load voltage (UL) are fed and monitored seper-
ately. If the voltage falls below the permissible voltage, the outputs are switched off. 

UL can be switched off. In this case, the module still communicated and the inputs 
are still read in.

In case of an undervoltage at UL, the "POWER" LED changes from green to red. In 
case of an undervoltage at UB, the "POWER" LED is turned off.
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Connection Possibilities

2

Power supply via 7/8’’ (FXEN-XSG16-0001-PN)

Power supply via M23×1 (FXEN-XSG16-0005-PN)

In-/ and Outputs

The module is equipped throughout with 5-pole metal M12- connectors for connection of the 
sensor/actuator level.

Figure 4:
7/8’’- male and 
female connec-
tor

Figure 5:
M23 x 1- male 
and female
connector

Note

For the pin assignment of the M12-connectors, please refer to the wiring diagrams 
in the module specific chapters of this manual. 
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FXEN - General Technical Features
SET-Button

Pressing the SET-button under the cover on the gateway for about 10 seconds is used to 
store the factory default values to the module.

This function is only available in the “PROFINET-Operation Mode“.

Default-values:

IP address: 0.0.0.0

Subnet mask: 0.0.0.0

Device name: TURCK-FXEN-default 

Attention

When storing the device name or the IP address or when resetting the gateway to 
the default values, the BUS-LED switches to orange. 

During this time, the gateway’s voltage supply must not be interrupted. In case of a 
power failure, faulty data will be stored in the gateway. 

Note

Resetting the gateway is only possible when the station is not connected to the 
fieldbus (no AR active).
D301136 0508 -  FXEN for PROFINET2-8



General Technical Data

2

General Technical Data 

Technical Data

Table 2:
Technical data 
of the FXEN-
modules

AIn case of low 
simultaneity 
factors and low 
ambient tem-
peratures, 
mounting dis-
tances of 
< 50 mm may 
be possible. 

Power supply

Operational voltage UB 18 to 30 V DC

Load voltage UL 18 to 30 V DC

Internal current consumption (via UB) < 200 mA

Connections nickel-plated brass connectors

PROFINET 2 x female M12 connector (OUT), 4-pole, d-coded

Power supply 7/8” connectors 
or
M23 x 1 connectors

Inputs/outputs female M12-connectors, 5-pole

Isolation voltages 

UBL (UB to UL ) none

UETH (supply voltage to Ethernet) 500 V AC

UCAN (supply voltage to CAN) none

UIO (IOs to supply voltage) none

UETHETH (ETH1 to ETH 2) 500 V AC

Housing Fibre-glass reinforced PA6 (PA6-GF30)

Dimensions 60,4 x 220,5 x 27 mm (width x length x height)

Mounting via 4 through-holes Ø 5.4 mm

Mounting distance
module/module

min. ≥ 50 mm A
Valid for operation in the ambient temperatures 
mentioned below, with sufficient ventilation as 
well as maximum load (horizontal mounting).

Degree of protection 
(IEC 60529/EN 60529)

IP67

Vibration resistance test acc. to EN 60068-2-6, IEC 68-2-47

Shock resistance test acc. to EN 60068-2-27

EMC acc. to EN 61000-6-2, EN 61000-6-4

Temperature range

– Operating temperature 0 °C to + 55 °C (+ 32 °F to + 131 °F)

– Storage and transport - 25 °C to + 70 °C (- 13 °F to + 158 °F)
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FXEN - General Technical Features
Dimension drawings

Figure 6:
Dimensions for 
the FXEN-mod-
ules

� �
�

�
���

	



�

�
�

�
�

��

��

	



�
�


���� �
�

� �
�

�
���

	



�
� �

�
�
���

	



�

���

����

���%�
���%�

��������

�%�

��%� ��

�����	�


��
�	

��

��

��

���
D301136 0508 -  FXEN for PROFINET2-10



General Technical Data

2

LED-Displays

Table 3:
LED-displays of 
the FXEN-
modules

LED Display Meaning Remedy

ETHx 
(blinking during 
data transfer)

green Link, 100 Mbps

green,
flashing

Ethernet Traffic 100 Mbps

yellow Link, 10 Mbps

yellow,
flashing

Ethernet Traffic 10 Mbps

off No Ethernet link – Check the Ethernet-
connection

U off UB < 18 VDC – Check the operating 
voltage 

green UB and UL, 
within the operating range

red UL < 18 VDC – Check the load voltage 

Cx.0 green 24 V at input/ output

red Overcurrent at output ot at 
sensor supply

Cx.1 green 24 V at input/ output

red Overcurrent at output ot at 
sensor supply

BUS green Logical connection to a 
PROFINET IO controller estab-
lished

green, 
flashing

The gateway has received a 
identification command from 
configurator

red No connection to a PROFINET 
IO controller established

orange Module is storing the device 
name or the IP address or is 
set back to its default values.
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FXEN - General Technical Features
Diagnostic Messages via Software

The diagnostic messages are displayed in the corresponding software of the PROFINET PLC 
as diagnostic error codes. 

For the meaning of the individual error codes for the FXEN-modules, please refer to the 
following section.

Diagnostic Messages (Slot 0 - "PROFINET-Communication")

Channel Specific Diagnostic Messages for the I/O-Channels (Slot 1)

see page 3-4, ”Diagnostic messages of the I/O-channels (Slot 1)”.

Table 4:
Module 
diagnostics 
"PROFINET-
communica-
tion"

Value (dec.) Diagnostic meaning

Error-Codes (1 to 9 acc. to specifications)

2 Undervoltage:
Undervoltage Channel 0: Undervoltage at UB 
Undervoltage Channel 1: Undervoltage at UL 
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General Parameters

2

General Parameters

For the FXEN-modules, one has to differentiate between the general PROFINET-parameters 
of the module and the specific parameters of the I/O-level.

The latter are explained in the descriptions for the I/O-level within the following chapters.

Table 5:
Parameters

Parameter name Value Meaning

Adefault-
setting

Module parameters- parameters for Slot 0

parameterization 0 = activate A The module receives its parameter 
settings from the controller, IO-super-
visor, I/O-ASSISTANT or similar.
In this case, parameter changes which 
were done in the meantime for example 
by a configuration tool or similar will be 
overwritten with the valid parameter 
data set.

1 = deactivate Changes in the parameter settings are 
stored permanently to the module and 
can thus not be overwritten by a 
controller, I/O-supervisor or similar in 
case of a re-start of the module. 

outputs fieldbus error 00 = output 0 A The gateway switches the outputs of the 
modules to "0”. No error information is 
transmitted.

01 = Hold current value The module maintains the actual output 
settings. 

diagnostics 0 = activate Diagnostic and alarm messages are 
generated.

1 = deactivate Diagnostic and alarm messages are 
suppressed.

UL diagnostics 0 = activate A The monitoring of the load voltage UL is 
activated.

1 = deactivate An eventually occurring under-voltage at 
UL will not be detected. 

Channel parameters for Slot 1 

The parameter description for the I/O-level can be found within the following chapters. 
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FXEN - General Technical Features
Description of User Data for Acyclic Services 

The acyclic data exchange is done via Record Data CRs (CR-> Communication Relation). 

Via these Record Data CRs the reading and writing of the following services is realized: 

Writing of AR data

Writing of configuration data

Reading and writing of device data

Reading of diagnostic data

Reading of I/O data

Reading of Identification Data Objects (I&M functions)

Reading of differences between the expected and the actually plugged modules 
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Description of User Data for Acyclic Services

2

Description of the Acyclic Gateway User Data

Table 6:
Gateway User 
Data

Index

(dec.)

Name Data 
type

r/w Remark

1 Gateway-Parameter DWORD r Parameter data the gateway

2 Gateway designation STRING r Productname of the gateway

3 Gateway revision STRING r Firmware-revision of the gateway

4 Vendor ID WORD r Ident number for TURCK

5 Gateway name STRING r Name assigned to the gateway

6 Gateway type STRING r Device type of the gateway

7 Device ID WORD r Ident number of the gateway

8 to 23 reserved

24 Gateway diagnosis WORD r Diagnosis data of the gateway

25 o 31 reserved

32 Module input list Array of 
BYTE

r List of all input channels in the 
station

33 Module output list Array of 
BYTE

r List of all output channels in the 
station

34 Modul diag. list Array of 
BYTE

r List of all module diagnosis 
messages

35 Module 
parameter list

Array of 
BYTE

r List of all module parameters

36 to 
45039

reserved

45040 I&M functions r/w Identification & Maintaining-
services 

45041 to 
45055 

I&M1 to IM15 
functions 

Actually not supported
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FXEN - General Technical Features
Description of the Acyclic Module User Data

Table 7:
Module User 
Data

Index

(dec.)

Name Data type r/w Remark

1 Modul parameters DWORD r Parameter rof the module

2 Modul type ENUM
UINT8

r Module type

3 Modul version UINT8 r Firmware-Revision of the module

4 Module ID DWORD r Ident number of the module

5 to 18 reserved

19 Input data specific r Input data of the respective 
module

20 to 22 reserved

23 Output data specific r/w Output data of the respective 
module

24 to 31 reserved

32 to 255 Profile-specific These indices are reserved for the data of several 
module profiles (e. g. RFID). The definitions of the 
profile indices can be found in the respective 
module descriptions.
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Digital Input Module FXEN-IM16-0001-PN
FXEN-IM16-0001-PN

The module offers 16 digital inputs for 3-wire-pnp sensors.

Technical Data

Wiring Diagram

Table 8:
Techncal data 
FXEN-IM16-
000x-PN

Designation FXEN-IM16-000x-PN

Configuration file GSDML-V2.0-Turck-FXEN16-JJJJMMTT.xml

Inputs (configurable) (n) 3 wire pnp sensors (n = 0...16)

Supply (via UB) 24 VDC (18... 30 VDC)

Supply current < 120 mA per connector, short-circuit 
protected

Switching threshold OFF/ON 2 mA/4 mA

Switching current 
limitation

6 mA

Switch-on delay 2,5 ms

Switching frequency < 250 Hz

Galvanic isolation galvanic isolation to Ethernet

Note

The general technical data for the FXEN-products can be found in Kapitel 2. 

Figure 7:
Wiring diagram

5 PE 4 BK

1 BN +

3 BU –

3 BU –

2 WH
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FXEN-IM16-0001-PN

3

Process Data Mapping

Process input data

Parameterization

The parameters described in the following are only valid for the I/O-level of the module
FXEN-IM16-0001-PN. 

Parameter Data Mapping

Bit 7 Bit 6 Bit 5 Bit 4 Bit 3 Bit 2 Bit 1 Bit 0

Byte 0 In7 In6 In5 In4 In3 In2 In1 In0

Byte 1 In15 In14 In13 In12 In11 In10 In 9 In 8

Table 9:
Parameters

Parameter name Value Meaning

A default 
settings

Module parameters for Slot 0 

The general parameters of the module’s PROFINET-level are described in the section 
„General Parameters”, page 2-13.

Channel parameters for Slot 1 

Digital input x 0 = normal A

1 = inverted

Bit 7 Bit 6 Bit 5 Bit 4 Bit 3 Bit 2 Bit 1 Bit 0

Byte 0 reserved reserved reserved reserved reserved reserved reserved reserved 

Byte 1 reserved reserved reserved reserved reserved reserved reserved reserved 

Byte 2 Invert7 Invert6 Invert5 Invert4 Invert3 Invert2 Invert1 Invert0

Byte 3 Invert15 Invert14 Invert13 Invert12 Invert11 Invert10 Invert9 Invert8
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Digital Input Module FXEN-IM16-0001-PN
Diagnostics

Diagnostic messages of the I/O-channels (Slot 1)

The channel-specific diagnostic messages are defined as follows:  

Diagnostic Data Mapping

ErrSensX:

0 = normal opreation

1 = Short circuit at sensor supply

Table 10:
Channel 
specific diag-
nostic 
messages 

Value (dec.) Diagnostic message

Error-Codes (1 to 9 acc. to specifications)

1 short-circuit

4 overload

Error-Codes (16 to 31, vendor specific)

16 Parameterization error
After a validity check, the parameter data are (partially) rejected by the 
module. Check the context of parameters.

21 Hardware failure
The module detected a hardware failure. Exchange the module.

24 User software error
The module detected an user application software error. Check the interop-
erability of the user application software revisions. Reinitialize user the appli-
cation software of the module.

26 Sensor supply load dump
The module detected a load dump at the sensor supply.

28 Common Error
The module detected an error. Refer to the
I/O-module manuals for a more detailed description of possible errors. Error 
types can depend on the operation mode and the parameterization.

Note

For the detection of a wirebreak in the sensor/ actuator cable, pin Pin 1 (UB - power 
supply) and pin 2 at the sensor and the actuator have to be bridged.

Bit 7 Bit 6 Bit 5 Bit 4 Bit 3 Bit 2 Bit 1 Bit 0

Byte 0 ErrSens7 ErrSens6 ErrSens5 ErrSens4 ErrSens3 ErrSens2 ErrSens1 ErrSens0
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Configurable I/O-Module FXEN-XSG16
FXEN-XSG16-000x-PN

The in- and output station FXEN-XSG16-000x is a modular PROFINET-slave in compact housing 
design. 
The module is equipped with sixteen channels, which can be configured differently depending on the 
specific application requirements. Up to sixteen 3-wire pnp sensors or sixteen DC actuators with a 
maximum output current of 1.4 A per output can be connected.
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FXEN-XSG16-000x-PN

4

Technical Data 

Block diagram

Table 11:
Technical data 
of 
FXEN-XSG16-
000x-PN

Designation FXEN-XSG16-000x-PN

Configuration file GSDML-V2.0-Turck-FXEN16-JJJJMMTT.xml

Inputs (configurable) (n) 3 wire pnp sensors (n = 0...16)

Supply (via UB) 24 VDC (18 ... 30 VDC)

Supply current < 120 mA per connector, short-circuit 
protected

Switching threshold OFF/ON 2 mA/4 mA

Switching current 
limitation

6 mA

Switch-on delay 2,5 ms

Switching frequency < 250 Hz

Galvanic isolation galvanic isolation to Ethernet

Outputs (configurable) (16-n) DC actuators (n = 0...16)

Load supply (via UL) 24 VDC (18 ... 30 VDC)

Output current 1.4 A, short-circuit protected (ON period = 
35 %)

Switching frequency < 250 Hz

Galvanic isolation galvanic isolation to Ethernet

Note

The general technical data for the FXEN-products can be found in Chapter 2. 

Figure 8:
Block diagram 
FXEN-XSG16-
000x-PN

Pin 2 = channel 1, 3, 5 ... (all impair channel numbers)
Pin 4 = channel 0, 2, 4 ...(all pair channel numbers)

�

� �

�

�

Input

Invert. Input

Output

U (24 V)B

GND

Input

Invert. Input

Output

A
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Configurable I/O-Module FXEN-XSG16
Wiring diagrams

Process Data Mapping

Process input data

Process output data

Figure 9:
Wiring diagrams

Connection of 2 actuators:

Connection of 2 sensors:

Combinations of sensor and actuator:

Bit 7 Bit 6 Bit 5 Bit 4 Bit 3 Bit 2 Bit 1 Bit 0
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FXEN-XSG16-000x-PN

4

Parameterization

The parameters described in the following are only valid for the I/O-level of the module 
FXEN-XSG16-000×-PN.

Parameter data mapping

Table 12:
Parameters

Parameter name Value Meaning

A default-
settings

Module parameters for Slot 0 

The general parameters of the module’s PROFINET-level are described in the section 
”General Parameters”, page 2-13.

Channel parameters for Slot 1 

Digital input x
(Invertx)

0 = normal A

1 = inverted

Output x
(OvlModx)

0 = deactivated A

1 = activated

Output on overcurrent x
(OutEnx)

0 = automatic recovery A 

1 = controlled recovery: 
The output is manually switched-off and on again.

Bit 7 Bit 6 Bit 5 Bit 4 Bit 3 Bit 2 Bit 1 Bit 0

Byte 0 reserved reserved reserved reserved reserved reserved reserved reserved 

Byte 1 reserved reserved reserved reserved reserved reserved reserved reserved 

Byte 2 Invert7 Invert6 Invert5 Invert4 Invert3 Invert2 Invert1 Invert0

Byte 3 Invert15 Invert14 Invert13 Invert12 Invert11 Invert10 Invert9 Invert8

Byte 4 OvlMod7 OvlMod6 OvlMod5 OvlMod4 OvlMod3 OvlMod2 OvlMod1 OvlMod0

Byte 5 OvlMod15 OvlMod14 OvlMod13 OvlMod12 OvlMod11 OvlMod10 OvlMod9 OvlMod8

Byte 6 OutEn7 OutEn6 OutEn5 OutEn4 OutEn3 OutEn2 OutEn1 OutEn1

Byte 7 OutEn15 OutEn14 OutEn13 OutEn12 OutEn11 OutEn10 OutEn9 OutEn8
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Configurable I/O-Module FXEN-XSG16
Diagnostics

Diagnostic messages of the I/O-channels (Slot 1)

The channel-specific diagnostic messages are defined as follows:

Diagnostic data mapping

ErrOut: 

0 = normal opreation

1 = Short circuit or overload at output x 

ErrSensX:

0 = normal opreation

1 = Short circuit at sensor supply

Table 13:
Channel 
specific diag-
nostic 
messages 

Value (dec.) Diagnostic message

Error-Codes (1 to 9 acc. to specifications)

1 short-circuit

4 overload

Error-Codes (16 to 31, vendor specific)

16 Parameterization error
After a validity check, the parameter data are (partially) rejected by the 
module. Check the context of parameters.

21 Hardware failure
The module detected a hardware failure. Exchange the module.

24 User software error
The module detected an user application software error. Check the interop-
erability of the user application software revisions. Reinitialize user the appli-
cation software of the module.

26 Sensor supply load dump
The module detected a load dump at the sensor supply.

28 Common Error
The module detected an error. Refer to the
I/O-module manuals for a more detailed description of possible errors. Error 
types can depend on the operation mode and the parameterization.

Note

For the detection of a wirebreak in the sensor/ actuator cable, pin Pin 1 (UB - power 
supply) and pin 2 at the sensor and the actuator have to be bridged.

Bit 7 Bit 6 Bit 5 Bit 4 Bit 3 Bit 2 Bit 1 Bit 0

Byte 0 ErrSens7 ErrSens6 ErrSens5 ErrSens4 ErrSens3 ErrSens2 ErrSens1 ErrSens0

Byte 1 ErrOut7 ErrOut6 ErrOut5 ErrOut4 ErrOut3 ErrOut2 ErrOut1 ErrOut0

Byte 3 ErrOut15 ErrOut14 ErrOut13 ErrOut12 ErrOut11 ErrOut10 ErrOut9 ErrOut8
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Coupling the FXEN-Modules for PROFINET IO to a Siemens Step 7
Application Example

For configuring the coupling of an FXEN-module to PROFINET with a Siemens PLC S7, the 
software tool "SIMATIC Manager" version 5.4 with Service Pack 2 from Siemens is used.

Hardware:

Siemens PLC S7, CPU 315F-2-PN/DP, 6ES7 315-2FH13-0AB0, firmware V2.3 

one module FXEN-XSG16-0001-PN

New Project in Simatic Manager

Create a new project in the Simatic Manager via "File → New...". 

Add a Simatic station using "Insert → Station". In this example, a station "Simatic 300-
Station" is used.

The Configuration of the PROFINET IO-network will be done afterwards in the Hardware 
Config. 

Setting the PG/PC Interface

In order to be able to build up a communication between PLC and your PG/PC via Ethernet, 
the respective interface/ network card of the PG/PC has to be activated. 

The interface’s settings is done in the dialog "PG/PC Interface". 

Figure 10:
Inserting a 
Simatic station
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Application Example

5

Open this dialog in the Simatic software for example via the "Options → Set PG/PC Inter-
face..." command or directly in the Windows Control Panel for your PG/PC. 

Figure 11:
Command "Set 
PG/PC Inter-
face"

Figure 12:
"Set PG/PC in-
terface" in the 
Control Panel
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Coupling the FXEN-Modules for PROFINET IO to a Siemens Step 7
Select your interface for the connection between S7 PLC and Ethernet-network and confirm 
the settings.

Installation of the GSD-files

In the hardware configuration "HW config", open the "Options → Install GSD file" command 
in order to install new GSDML-files.  

Figure 13:
Select PG/PC 
interface 

Figure 14:
Install GSD-files
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Application Example

5

Define the directory for the TURCK GSDML-files by browsing the directories and add the 
FXEN-module to the hardware catalog. 

The FXEN-module can now be found under "PROFINET IO → Additional Field Devices →
I/O →  TURCK". 

Now, choose the profile rack "RACK-300" for the Siemens CPU from the catalog and add it 
to the network window. 

Figure 15:
Install GSD-file

Figure 16:
FXEN-module in 
the hardware 
catalog
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Coupling the FXEN-Modules for PROFINET IO to a Siemens Step 7
After this, select the Siemens CPU from the hardware catalog. In this example a CPU 315-2 
PN/DP, version 6ES7 315-2EG10-0AB0 (V 2.3.2) is used.

In the dialog "Properties Ethernet Interface", the IP address and the subnet mask for the S7 
CPU are defined.

Figure 17:
Selecting the 
CPU

Figure 18:
Properties 
Ethernet inter-
face
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Application Example

5

The subnet is added using the "New..." button. 

Now, the FXEN-module is chosen from the hardware catalog and added to the configuration. 

Select the module under "PROFINET IO → Additional Field Devices → I/O → TURCK" and 
add it to the Ethernet-network.

A double-click on the module-symbol opens the dialog "Properties TURCK". Enter the 
module’s device name in this dialog.  

Figure 19:
Add new Ether-
net subnet

Figure 20:
Select FXEN-
Module

Note

When being operated for the first time, the default-device name of the TURCK 
FXEN-modules for PROFINET is "TURCK-FXEN-default". The IP-Address is 0.0.0.0.
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Coupling the FXEN-Modules for PROFINET IO to a Siemens Step 7
Scanning the network for PROFINET IO Nodes

The Simatic hardware configuration offers the possibility to browse the PROFINET IO network 
using a broadcast command in order to find active PROFINET IO nodes. The active nodes are 
identified via their MAC address.

Figure 21:
Dialog box: 
Properties 
TURCK

Attention

In PROFINET IO, the connected device is not identified by it’s IP address, but rec-
ognized and addressed by it’s device name. 

The selection of a device name for a special I/O device can thus be compared to the 
setting of the PROFIBUS address for a DP slave. 

The device name can be freely chosen.

Attention

When storing the device name or the IP address or when resetting the module to the 
default values, the BUS-LED switches to orange. 

During this time, the module’s voltage supply must not be interrupted. In case of a 
power failure, faulty data will be stored in the module. 
D301136 0508 -  FXEN for PROFINET5-8



Application Example

5

Open the respective dialog box by using "PLC → Ethernet → Edit Ethernet Node". 

Browse the network for active network nodes identified by means of their MAC address, by 
using the button "Browse" in the field "Ethernet node". 

All PROFINET IO nodes found in the network answer the command sending their MAC 
address and their device name.

Select a node and close the dialog with "OK". 

The features of the selected node are now shown in the in the dialog "Edit Ethernet Node". 

Figure 22:
Configure 
Ethernet node 

Figure 23:
Browse the 
network
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Coupling the FXEN-Modules for PROFINET IO to a Siemens Step 7
In this dialog, the node’s IP configuration or device name can be adapted, if necessary for the 
application. 

Figure 24:
Adaptation of 
the Ethernet 
node configura-
tion

Attention

Here, you can also assign an application specific device name to the devices which 
were found.

Please observe, that the device name assigned here has to be 

similar to the device name assigned to the node in the properties 

dialog box (see Figure 28: "Dialog box: Properties TURCK").

If this is not guaranteed, the PLC will not be able to clearly identify the node! 
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Diagnostics with Step 7

5

Diagnostics with Step 7 

Diagnostic Messages in the Hardware Configuration

The FXEN-modules for PROFINET show general module diagnostics and channel-specific 
diagnostics in the hardware configuration of the Step 7-software.

Furthermore a special help text, which clearly specifies the error, is given for each diagnostic 
message:

Diagnostics Evaluation in the Application Program

In PROFINET IO, a vendor-independent structure for data records with diagnostic information 
has been defined. Diagnostic information is generated only for disturbed channels. 

The following pages show two possibilities for diagnosis evaluation within an application 
program.   

Figure 25:
Diagnosis of the 
PROFINET 
FXEN-modules 
in the hardware 
config

A channel-spe-
cific module 
diagnosis 

B manufacturer- 
specific help 
texts

Note

Please refer to the Step 7 online help or the respective Simatic documentation 
("PROFINET IO - From PROFIBUS DP to PROFINET IO - Programming manual", 
document number A5E00298268-02) for all complete and actual information about 
the diagnosis evaluation. 

A

B
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Coupling the FXEN-Modules for PROFINET IO to a Siemens Step 7
Diagnostics with SFB 52 in OB1

Using the SFB52, the diagnosis evaluation is done with every cycle of the application 
program.

In principle, SFB 52 can be called in any organization block. 

Note

Please refer to the complete and actual description of SFB 52 in the software’s on-
line help. 

Table 14:
input data 
SFB 52

Parameter name Meaning 

REQ REQ = 1, starts data transfer 

ID Logical address (HW config) of the module to be addressed.
When addressing the gateway, the Diagnostic address given in HW 
config has to be entered. 
Note:
If the module is an output module, bit 15 has to be set (example: for 
address 5: ID: = DW#16#8005). In combi-modules, the smaller of the 
two addresses should be specified.

INDEX Data record number; in PROFINET specify the number of the 
PROFINET diagnosis data record for the reading of channel diagnosis 
(diagnosis data records: W#16#800Ahex to W#16#E00Ahex, according to 
PROFINET specification). 

MLEN Maximum length of the data to be read.

Table 15:
output data 
SFB 52

Parameter name Meaning

VALID New data record has been received and is valid. 

BUSY BUSY = 1: 
The read operation is not yet complete. 

ERROR ERROR = 1: 
An error occurred during the read operation

STATUS Error code of the function block (see Siemens online help for SFB54 
"RALRAM")

LEN Length of loaded data.

RECORD Destination area for the read data record.
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Diagnostics with Step 7

5

Diagnostics with SFB 54 in case of error/ alarm in the alarm OB

Signal and function modules with diagnosis function detect interrupts and generate a diag-
nosis alarm. A response to this alarm is done via alarm Organization Blocks. 

Based on the OB number and start information for the interrupt event, you already have some 
first information about its cause and location. 

Detailed information about the interrupt event in this error OB can be read using SFB 54 (Read 
supplementary interrupt information). 

The interrupt evaluation is done as follows: 

Diagnostic event:

→ Alarm-OB is called

→ SFB 54 is called.

→ Diagnostic data is stored in the AINFO (header information and supplementary interrupt 
information) and TINFO (OB start information and housekeeping information) destination 
areas. 

Note

Please refer to the Step 7 online help or the respective Simatic documentation 
("PROFINET IO - From PROFIBUS DP to PROFINET IO - Programming manual", 
document number A5E00298268-02) for all complete and actual information about 
the diagnosis evaluation.

Table 16:
input data 
SFB 54

Parameter name Meaning

MODE Operation mode

F_ID Logical start address of the module from which interrupt information 
should be received.

MLEN Maximum length of diagnosis information to be received in bytes.

Table 17:
output data 
SFB 54

Parameter name Meaning

NEW A new interrupt has been received. 

STATUS Error code of SFB or IO controller.

ID Start address of component (module) from which an interrupt was 
received Bit 15 contains the I/O identifier: 
"0" for an input address, 
"1" for an output address.

LEN Length of the received interrupt information in bytes.

TINFO (Task information) Destination area for OB start information and house-
keeping information. 

AINFO (Alarm information) Destination area for header information and supple-
mentary interrupt information.
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Coupling the FXEN-Modules for PROFINET IO to a Siemens Step 7
Note

Please refer to the Step 7 online help or the respective Simatic documentation 
("PROFINET IO - From PROFIBUS DP to PROFINET IO - Programming manual", 
document number A5E00298268-02) for all complete and actual information about 
the AINFO and TINFO. 
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Coupling the FXEN-Modules for PROFINET IO to the PLC ILC 370 PN 2TX-IB from Phoenix 
Application Example

For configuring the coupling of an FXEN-module to PROFINET with a Phoenix Contact PLC 
ILC 370 PN 2TX-IB, the software tool PC WorX, version 5.10.22, SP 2.3.1 is used.

Hardware:

Phoenix Contact PLC ILC 370 PN 2TX-IB Rev.01/4.6F/142

one module FXEN-XSG16-0001-PN

New Project in PC WorX

Open the dialog "New Project" using the "File → New Project..." command and select the PLC 
used in your project. In this example, we use a ILC 370 PN 2TX-IB.

Save the project using the "File → Save Project As.../ Zip Project As...". The project is gener-
ated. 

Figure 26:
Selection of the 
PROFINET PLC
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Bus Configuration

The configuration of the PROFINET IO-network is done in the "Bus Configuration" part of the 
software. It is opened using the "View → Bus configuration" command.

Figure 27:
Opening the 
Bus 
Configuration
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Coupling the FXEN-Modules for PROFINET IO to the PLC ILC 370 PN 2TX-IB from Phoenix 
Activating the Communication Interface

In order to be able to build up the communication between the PLC and your PC via Ethernet, 
the respective interface/ network card has to be activated. 

The interface’s activation is done via the "Extras → PROFINET configuration..." command. 
Chose the used interface card in the dialog "PROIFNET" 

IP-Settings in the Project

The IP-settings of the entire PC WorX project have to be adapted to the application. 

Open the dialog box "Bus Structure" using the "View → Bus Structure" command and the 
dialog box "Device Details" using the "View → Device Details" command. 

Mark the project name in the Bus Structure and set the "First IP Address" and the "Last IP 
Address" for the project according to your application. 

Figure 28:
"PROFINET 
configuration" 
command

Figure 29:
Device Details 
of the project
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Configuration of the PLC

If necessary, the IP settings of the PLC have to be adapted, too. 

Doubleclick the PLC entry in the Bus Structure and enter the PLC’s IP address in the respec-
tive row. 

Import of the GSD-Files

The GSD-file import is done in the Bus Configuration in the dialog box "Device Catalog". Open 
it using the "View → Device Catalog" command.

A right click in the Device Catalog opens the context menu. Open the import dialog box using 
the "Import GSD File..." command. 

Define the GSD-file’s storage position, install it and add the FXEN-module for PROFINET to 
the Device Catalog. 

Figure 30:
Device Details 
for the PLC
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Coupling the FXEN-Modules for PROFINET IO to the PLC ILC 370 PN 2TX-IB from Phoenix 
The FXEN-module is now listed in the Device Catalog under "Hans Turck GmbH & Co. KG 
→ I/O → TURCK". 

Adding the FXEN-Module to the Bus Configuration

Adding the module to the PROFINET network can be done manually or automatically (see 
section “Scanning the Network for PROFINET IO-Nodes“)

Mark the entry "PROFINET" in the Bus Configuration. A doubleclick on the module-entry in 
the Device Catalog adds the FXEN to the Bus Structure. 

Scanning the Network for PROFINET IO-Nodes

PC WorX offers the possibility to scan the network for active PROFINET-nodes using a Broad-
cast commend. The nodes are identified by means of their MAC-ID.

Figure 31:
FXEN in the 
Device Catalog

Attention

In PROFINET IO, the connected device is not identified by it’s IP address, but rec-
ognized and addressed by it’s device name. 

The selection of a device name for a special I/O device can thus be compared to the 
setting of the PROFIBUS address for a DP slave. 

The device name can be freely chosen.
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Open the context menu with an right-click on the "PROFINET"-entry and select the 
option "Read PROFINET...". 

Figure 32:
Read 
PROFINET 

o
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Coupling the FXEN-Modules for PROFINET IO to the PLC ILC 370 PN 2TX-IB from Phoenix 
All PROFINET IO nodes found in the network answer the command sending their MAC 
address and their device name.

Select the FXEN-module and close the dialog box. 

Figure 33:
Read 
PROFINET 

Note

When being operated for the first time, the default-device name of the FXEN-mod-
ules for PROFINET is "TURCK-FXEN-default". The IP-Address is 0.0.0.0.
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The module will be added to the "Bus Structure". The software PC WorX automatically 
assigns an IP address to the module. In the dialog box "Device Details", both, the IP address 
as well as the PROFINET-name of the node can be changed according to the application. 

Compiling a Project

If you compile a project for the first time, use the "Build → Rebuild Project" command.

After the compilation load the project to the PLC. Open the dialog box "STD-RES" via "Online 
Project Control...". In this dialog box, you can send new projects, new programs, changes etc. 
to the PLC. 

Figure 34:
Device Details 
FXEN
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Coupling the FXEN-Modules for PROFINET IO to the PLC ILC 370 PN 2TX-IB from Phoenix 
Press the Download button to send the Bus Configuration to the PLC and restart the PLC 
using the "Warm" button. 

After a successful download of the Bus Configuration the module’s BUS-LED changes from 
"red" to "green" and the bus communication is running. 

Figure 35:
Download of the 
Bus 
Configuration
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Guidelines for Electrical Installation
General Notes

General

Cables should be grouped together, for example: signal cables, data cables, heavy current 
cables, power supply cables. 

Heavy current cables and signal or data cables should always be routed in separate cable 
ducts or bundles. Signal and data cables must always be routed as close as possible to 
ground potential surfaces (for example support bars, cabinet sides etc.).

Cable Routing

Correct cable routing prevents or suppresses the reciprocal influencing of parallel routed 
cables.

Cable Routing Inside and Outside of Cabinets:

To ensure EMC-compatible cable routing, the cables should be grouped as follows:

Various types of cables within the groups can be routed together in bundles or in cable ducts. 

Group 1: 

shielded bus and data cables

shielded analog cables

unshielded cables for DC voltage ≤ 60 V

unshielded cables for AC voltage ≤ 25 V

Group 2: 

unshielded cables for DC voltage > 60 V and ≤ 400 V

unshielded cables for AC voltage > 25 V and ≤ 400 V

Group 3: 

unshielded cables for DC and AC voltages > 400 V

The following group combination can be routed only in separate bundles or separate cable 
ducts (no minimum distance apart):

Group 1/Group 2

The group combinations:

Group 1/Group 3 and Group 2/Group 3

must be routed in separate cable ducts with a minimum distance of 10 cm apart. This is 
equally valid for inside buildings as well as for inside and outside of switchgear cabinets.

Cable Routing Outside Buildings

Outside of buildings, cables should be routed in closed (where possible), cage-type cable 
ducts made of metal. The cable duct joints must be electrically connected and the cable ducts 
must be earthed.

Warning

Observe all valid guidelines concerning internal and external lightning protection 
and grounding specifications when routing cables outside of buildings.
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Lightning Protection

The cables must be routed in double-grounded metal piping or in reinforced concrete cable 
ducts. 

Signal cables must be protected against overvoltage by varistors or inert-gas filled over-
voltage arrestors. Varistors and overvoltage arrestors must be installed at the point where the 
cables enter the building.

Transmission Media

For a communication via Ethernet, different transmission media can be used: 

coaxial cable 
10Base2 (thin koax), 
10Base5 (thick koax, yellow cable)

optical fibre (10BaseF) 

twisted two-wire cable (10BaseT) with shielding (STP) or without shielding (UTP). 

Note

TURCK offers a variety of cable types for fieldbus lines as premoulded or bulk ca-
bles with different connectors. 

The ordering information for the available cable types can be found in the fieldbus 
technology catalog. 
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Potential Relationships

The potential relationship of a Ethernet system realized with FXEN-modules is characterized 
as shown in the following figure:

Figure 36:
Block diagram 
of FXEN-station

Ethernet

UBUB GND

I >

Inputs Outputs

ULUL
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Electromagnetic Compatibility (EMC)

FXEN products comply in full with the requirements pertaining to EMC regulations. 

Nevertheless, an EMC plan should be made before installation. Hereby, all potential electro-
mechanical sources of interference should be considered such as galvanic, inductive and 
capacitive couplings as well as radiation couplings.

Ensuring Electromagnetic Compatibility

The EMC of FXEN modules is guaranteed when the following basic rules are adhered to:

Correct and large surface grounding of inactive metal components.

Correct shielding of cables and devices. The grounding lug at the Ethernet-connectors has 
to be connected as low-impedance as possible to earth. 

Proper cable routing – correct wiring.

Creation of a standard reference potential and grounding of all electrically operated 
devices.

Special EMC measures for special applications.

Grounding of Inactive Metal Components

All inactive metal components (for example: switchgear cabinets, switchgear cabinet doors, 
supporting bars, mounting plates, tophat rails, etc.) must be connected to one another over 
a large surface area and with a low impedance (grounding). This guarantees a standardized 
reference potential area for all control elements and reduces the influence of coupled distur-
bances.

In the areas of screw connections, the painted, anodized or isolated metal components 
must be freed of the isolating layer. Protect the points of contact against rust.

Connect all free moving groundable components (cabinet doors, separate mounting 
plates, etc.) by using short bonding straps to large surface areas.

Avoid the use of aluminum components, as its quick oxidizing properties make it unsuit-
able for grounding.

PE Connection

A central connection must be established between ground and PE connection (protective 
earth).

Warning

The grounding must never – including cases of error – take on a dangerous touch 
potential. For this reason, always protect the ground potential with a protective ca-
ble.
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Shielding of Cables

Shielding is used to prevent interference from voltages and the radiation of interference fields 
by cables. Therefore, use only shielded cables with shielding braids made from good 
conducting materials (copper or aluminum) with a minimum degree of coverage of 80 %.

The cable shield should always be connected to both sides of the respective reference poten-
tial (if no exception is made, for example, such as high-resistant, symmetrical, analog signal 
cables). Only then can the cable shield attain the best results possible against electrical and 
magnetic fields.

A one-sided shield connection merely achieves an isolation against electrical fields.

The insulation of the shielded data-cable should be stripped and connected to the shield rail 
when the system is not in operation. The connection and securing of the shield should be 
made using metal shield clamps. The shield clamps must enclose the shielding braid and in 
so doing create a large surface contact area. The shield rail must have a low impedance (for 
example, fixing points of 10 to 20 cm apart) and be connected to a reference potential area. 

The cable shield should not be severed, but routed further within the system (for example, to 
the switchgear cabinet), right up to the interface connection.

Attention

When installing, please pay attention to the following...

– the shield should be connected immediately when entering the system,
– the shield connection to the shield rail should be of low impedance,
– the stripped cable-ends are to be kept as short as possible,
– the cable shield is not to be used as a bonding conductor.

If the data cable is connected via a SUB-D connector, the shielding should never be 
connected via pin 1, but to the mass collar of the plug-in connector.

Note

Should it not be possible to ground the shield on both sides due to switching ar-
rangements or device specific reasons, then it is possible to route the second cable 
shield side to the local reference potential via a capacitor (short connection distanc-
es). If necessary, a varistor can be connected parallel to the capacitor, to prevent 
disruptive discharges of the capacitor when interference pulses occur.

A further possibility is a double-shielded cable (galvanically separated), whereby the 
innermost shield is connected on one side and the outermost shield is connected 
on both sides.
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Potential Compensation

Potential differences can occur between installation components that are in separate areas 
and these

are fed by different supplies,

have double-sided conductor shields which are grounded on different installation compo-
nents.

A potential-compensation cable must be routed to the potential compensation. 

A potential compensation cable must have the following characteristics:

Low impedance. In the case of compensation cables that are routed on both sides, the 
compensation line impedance must be considerably smaller than that of the shield 
connection (max. 10 % of shield connection impedance).

Should the length of the compensation cable be less than 200 m, then its cross-section 
must be at least 16 mm2 / 0.025 inch2. If the cable length is greater than 200 m, then a 
cross-section of at least 25 mm2 / 0.039 inch2 is required.

The compensation cable must be made of copper or zinc coated steel.

The compensation cable must be connected to the protective conductor over a large 
surface area and must be protected against corrosion.

Compensation cables and data cables should be routed as close together as possible, 
meaning the enclosed area should be kept as small as possible.

Switching Inductive Loads

In the case of inductive loads, a protective circuit on the load is recommended.

Protection against Electrostatic Discharge (ESD

Warning

Never use the shield as a potential compensation.

Attention

Electronic modules and base modules are at risk from electrostatic discharge when 
disassembled. Avoid touching the bus connections with bare fingers as this can 
lead to ESD damage.
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9 Glossary

Acknowledge

Acknowledgment of a signal received.

Active metal component

Conductor or conducting component that is electrically live during operation.

Address

Identification number of, e.g. a memory position, a system or a module within a network.

Addressing

Allocation or setting of an address, e. g. for a module in a network.

Analog

Infinitely variable value, e. g. voltage. The value of an analog signal can take on any value, within certain 
limits.

Automation device

A device connected to a technical process with inputs and outputs for control. Programmable Logic 
Controllers (PLC) are a special group of automation devices.

Baud

Baud is a measure for the transmission speed of data. 1 Baud corresponds to the transmission of one 
bit per second (Bit/s).

Baud rate

Unit of measurement for measuring data transmission speeds in Bit/s.

Bidirectional

Working in both directions.

Bus

Bus system for data exchange, e. g. between CPU, memory and I/O levels. A bus can consist of several 
parallel cables for data transmission, addressing, control and power supply.

Bus cycle time

Time required for a master to serve all slaves or stations in a bus system, i. e. reading inputs and writing 
outputs.

Bus line

Smallest unit connected to a bus, consisting of a PLC, a coupling element for modules on the bus and 
a module.

Bus system

All units which communicate with one another via a bus.

Capacitive coupling

Electrical capacitive couplings occur between cables with different potentials. Typical sources of inter-
ference are, for example, parallel-routed signal cables, contactors and electrostatic discharges.

A

B

C
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Coding elements

Two-piece element for the unambiguous assignment of electronic and base modules.

Configuration

Systematic arrangement of the I/O modules of a station.

CPU

Central Processing Unit. Central unit for electronic data processing, the processing core of the PC.

Digital

A value (e. g. a voltage) which can adopt only certain statuses within a finite set, mostly defined as 0 
and 1.

DIN

German acronym for German Industrial Standard.

EIA

Electronic Industries Association – association of electrical companies in the United States.

Electrical components

All objects that produce, convert, transmit, distribute or utilize electrical power (e. g. conductors, cable, 
machines, control devices).

EMC

Electromagnetic compatibility – the ability of an electrical part to operate in a specific environment 
without fault and without exerting a negative influence on its environment.

EN

German acronym for European Standard.

ESD

Electrostatic Discharge.

Field power supply

Voltage supply for devices in the field as well as the signal voltage.

Fieldbus

Data network on sensor/actuator level. A fieldbus connects the equipment on the field level. Charac-
teristics of a fieldbus are a high transmission security and real-time behavior.

GND

Abbreviation of ground (potential „0“).

Ground

Expression used in electrical engineering to describe an area whose electrical potential is equal to zero 
at any given point. In neutral grounding devices, the potential is not necessarily zero, and one speaks 
of the ground reference.

Ground connection

One or more components that have a good and direct contact to earth.

D

E

F

G
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Ground reference

Potential of ground in a neutral grounding device. Unlike earth whose potential is always zero, it may 
have a potential other than zero.

GSD

Acronym for Electronic Device Data Sheet which contains standardized PROFIBUS DP station descrip-
tions. They simplify the planning of the DP master and slaves. Default language is English.

Hexadecimal

System of representing numbers in base 16 with the digits 0... 9, and further with the letters A, B, C, D, 
E and F.

Hysteresis

A sensor can get caught up at a certain point, and then “waver“ at this position. This condition results 
in the counter content fluctuating around a given value. Should a reference value be within this fluctu-
ating range, then the relevant output would be turned on and off in rhythm with the fluctuating signal.

I/O

Input/output.

Impedance

Total effective resistance that a component or circuit has for an alternating current at a specific 
frequency.

Inactive metal components

Conductive components that cannot be touched and are electrically isolated from active metal compo-
nents by insulation, but can adopt voltage in the event of a fault.

Inductive coupling

Magnetic inductive couplings occur between two cables through which an electrical current is flowing. 
The magnetic effect caused by the electrical currents induces an interference voltage. Typical sources 
of interference are for example, transformers, motors, parallel-routed network and HF signal cables.

Intelligent modules

Intelligent modules are modules with an internal memory, able to transmit certain commands (e. g. 
substitute values and others).

Load value

Predefined value for the counter module with which the count process begins.

Lightning protection

All measures taken to protect a system from damage due to overvoltages caused by lightning strike.

Low impedance connection

Connection with a low AC impedance.

LSB

Least Significant Bit

H

I

L

D301136 0508 -  FXEN for PROFINET 9-3



Glossary
Mass

All interconnected inactive components that do not take on a dangerous touch potential in the case of 
a fault.

Master

Station in a bus system that controls the communication between the other stations.

Master/slave mode

Mode of operation in which a station acting as a master controls the communication between other 
stations in a bus system.

Module bus

The module bus is the internal bus in a BL20 station. The BL20 modules communicate with the gateway 
via the module bus which is independent of the fieldbus.

MSB

Most Significant Bit

Multi-master mode

Operating mode in which all stations in a system communicate with equal rights via the bus.

NAMUR

German acronym for an association concerned with standardizing measurement and control engi-
neering. NAMUR initiators are special versions of the two-wire initiators. NAMUR initiators are charac-
terized by their high immunity to interference and operating reliability, due to their special construction 
(low internal resistance, few components and compact design).

Overhead

System administration time required by the system for each transmission cycle.

PLC

Programmable Logic Controller.

Potential compensation

The alignment of electrical levels of electrical components and external conductive components by 
means of an electrical connection.

Potential free

Galvanic isolation of the reference potentials in I/O modules of the control and load circuits.

Potential linked

Electrical connection of the reference potentials in I/O modules of the control and load circuits.

PROFIBUS-DP

PROFIBUS bus system with DP protocol. DP stands for decentralized periphery. PROFIBUS-DP is 
based on DIN 19245 Parts 1 + 3 and has been integrated into the European fieldbus standard EN 
50170.
It ensures a fast cyclic data exchange between the central DP master and the decentralized periphery 
devices (slaves). Its universal use is realized by the multi master concept.

M

N

O

P
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PROFIBUS-DP address

Each PROFIBUS-DP module is assigned an explicit PROFIBUS-DP address, with which it can be 
queried by the master.

PROFIBUS-DP master

The PROFIBUS-DP master is the central station on the bus and controls access of all stations to 
PROFIBUS.

PROFIBUS-DP slave

PROFIBUS-DP slaves are queried by the PROFIBUS-DP master and exchange data with the master on 
request.

Protective earth

Electrical conductor for protection against dangerous shock currents. Generally represented by PE 
(protective earth).

Radiation coupling

A radiation coupling appears when an electromagnetic wave hits a conductive structure. Voltages and 
currents are induced by the collision. Typical sources of interference are for example, sparking gaps 
(spark plugs, commutators from electric motors) and transmitters (e. g. radio), that are operated near 
to conducting structures.

Reaction time

The time required in a bus system between a reading operation being sent and the receipt of an answer. 
It is the time required by an input module to change a signal at its input until the signal is sent to the 
bus system.

Reference potential

Potential from which all voltages of connected circuits are viewed and/or measured.

Repeater

The phase and the amplitude of the electric data signals are regenerated during the transmission 
process by the repeater. 
Further, it is possible to change the topology of the PROFIBUS network. It can be extended consider-
ably by means of the repeater.

Root-connecting

Creating a new potential group using a power distribution module. This allows sensors and loads to be 
supplied individually.

RS 485

Serial interface in accordance with EIA standards, for fast data transmission via multiple transmitters.

Serial

Type of information transmission, by which data is transmitted bit by bit via a cable.

Setting parameters

Setting parameters of individual stations on the bus and their modules in the configuration software of 
the master.

R

S
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Shield

Conductive screen of cables, enclosures and cabinets.

Shielding

Description of all measures and devices used to join installation components to the shield.

Short-circuit proof

Characteristic of electrical components. A short-circuit proof part withstands thermal and dynamic 
loads which can occur at its place of installation due to a short circuit.

Station

A functional unit or I/O components consisting of a number of elements.

SUB-D connector

9-pin connector for connecting the fieldbus to the I/O-stations.

Terminating resistor

Resistor on both ends of a bus cable used to prevent interfering signal reflections and which provides 
bus cable matching. Terminating resistors must always be the last component at the end of a bus 
segment.

To ground

Connection of a conductive component with the grounding connection via a grounding installation.

Topology

Geometrical structure of a network or the circuitry arrangement.

UART

Universal Asynchronous Receiver/Transmitter. UART is a logic circuit which is used to convert an asyn-
chronous serial data sequence to a parallel bit sequence or vice versa.

Unidirectional

Working in one direction.

T

U
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